Matter of Acceleration

Discussion in 'G-Class' started by Zuhair Lardhi, May 22, 2017.

  1. Zuhair Lardhi

    Zuhair Lardhi New Member

    Hello there,

    I bought the G500 a few months ago. I feel the car doesn't have the power it should have. It feels sluggish.

    The car was checked by a mechanic and found no faults.

    Thanks
     
  2. laberia

    laberia Member

    This is what I would do. Change the air filters. Change the spark plugs. Change the engine oil and filters. Run one or two bottles of Techron fuel additive by missing it with the fuel. These things should make a difference.
     
  3. Zuhair Lardhi

    Zuhair Lardhi New Member

    Many thanks for your reply Laberia
    I have done all but still the loss of power exist. Do you think the airflow sensor is the culprit?

    Regards
     
  4. laberia

    laberia Member

    It very well could but the thing is that the MAF sensor usually triggers a fault code.


    What other symptoms do you notice? Also have you scaned the codes?
     
  5. Zuhair Lardhi

    Zuhair Lardhi New Member

    Hi

    I finally scanned the codes. All is clear and nothing was reported. I noticed the other day after driving around for an hour the car was shaking and losing power at a stop light.

    I will add athe fuel additives and see what happens next.
    Someone told me it might be the paddles sensor !

    Thanks and regards
     
  6. laberia

    laberia Member

    Yes it can be the pedal accelerator pedal. I would check the Mass Air Flow sensor as well. They are prone to failure. Cheap and easy to replace.
     
  7. Kajtek1

    Kajtek1 Awesome Member

    Any sensor will trigger a code and eventually CEL.
    What will not are filters.
     

Share This Page