Home > Contact Mercedes-Medic

Contact Mercedes-Medic

If you need help with your Mercedes-Benz you are welcome to ask questions in YOUCANIC Question and Answer section.

 

Please ask your question on our Forum, link provided above.

ONLY use email contact us form below for questions related to:

  • Advertising
  • Feedback
  • Abuse
  • Jobs
  • Website Errors
  • Website Problems

This form should NOT be used to submit a car questions.

Contact Us

Mercedes Medic
PO Box 8477
8201 Harford Rd,
Parkville, MD 21234

 

Email us at: 

Do not email car questions. If you have car questions, ask car questions here. 

25 comments

  1. Hi Guys. My fathers CL55 AMG has this EIS cold start problem & the mileage has shot up from 93’000 to 155’000 miles. The local Mercedes dealer will change the EIS, but can’t guarantee that the mileage will return to 93’000 miles as before. In your opinion do you think that this incorrect mileage issue can be resolved by simply replacing the EIS?

  2. W212 Mercedes E300 Hybrid – I have 2 fault codes P060C00 (Internal control unit fault in central processing unit) and P08700 (Oil pressure sensor/oil pressure switch ‘C’ has an electrical fault) both regarding transmission.

  3. Hi ! Recently i mounted on my car{w220 2005} a soft close assist system for doors . I try to program the PSE pump for this operation with STAR C3 , but i don t know how .

  4. Just ‘found’ your site and have to say a most excellent ‘find’ very informative and helpful. Although my particular motor is not one sold in the US (W211/E270cdi) it still has much in common with those E class models marketed there.

  5. If anyone can help i will be truly grateful. I have a 2005 E270cdi Estate right hand drive. Been having major probs with Air Suspension. the control module in passenger footwell had gone pop, ripped airbag, replaced airbag no probs. The control module has been replaced but I now have a fault message saying Y36/8y2 right rear level control valve internal short, problem is I cant find Y36/8y2 anywhere, I have looked all over web no mention. Any help please, am an Ex soldier and am disabled so rely on this car

  6. Need help fixing car mercedes c class 320 , something is causing battery to drain , can you tell me what it is

  7. Hello I have a 2006 CLS 500 8CYL W219 and that Transmission fluid cap is not in the back of the engine, and I went and ordered the dipstick, fluid, and cap locks already, Where is mine located? Please Help!
    Reply

  8. Thanks for being so resourceful guys. Love your site, and I am finding it very useful. Look forward to many more miles and smiles on my W220 🙂

  9. hi, I have a E class and it is new. the Play Command for Ipod worked fine but somehow when i connected my new Iphone, the voice command doesnt work. when i say Play ” and name a song” It says Function not possible. i dont know what else to do, i rely on that function a lot.

  10. THANK YOU! W163 I recently (March 7, 2017) purchased this 1999 ML 320 with 105k with 2 previous owners, this is my first Mercedes-Benz and I am thrilled to no end. I paid $3500.00 and continues to exceed my expectations.

    I am compelled to write because this site has been an amazing resource. I found an article on how to reset the transmission ECU so it would adapt to my driving style. You were right that its like getting a new transmission. It is AWESOME! This is a great demonstration of thoughtfulness by engineers and that one size does not fit all. I LOVE that! I’m sure this was “cutting edge” in 1999 and this probably what MB does, its fun to experience this, even in a vehicle that is 18yrs old. I am very happy, thanks for being part of making this possible.

    AK

  11. I have just part exchanged my ml for a glc coupe. Wished I hadn’t. It’s difficult to describe but when reversing and turning its like my old ML on snow. I certainly don’t like it. The merc dealer says it’s normal on new models now. GLC is brand new car but I prefer my old ml. What’s wrong with me?

  12. Hi.

    I have a W210 E50 AMG year 1996. The problem is that the instrument cluster sometimes works. Speed, speed, fuel level and temperature need not always work. The temperature needle closes shivering. In addition, M119 5.0 V8 engine sometimes pulls and other times normal operation. Exhaust gas levels are very high.

  13. bhaugeerutty parsooram

    HI..I HAV A MERCEDES E 270 CDI W211, YEAR 2004, AUTOMATIC TRANSMISSION. WITH 210K KMS + ON THE DASH…SINCE 2 WEEKS MY CAR IS GOING ON LIMP MODE WITH P 0236 FAULT CODES..I CHANGED THE TURBO N ITS ELECTRONIC ACTUATOR, THE MAF SENSOR, N THE TURBO BOOST SENSOR,,BUT IT IS STILL GOING ON LIMP MODE…CAN U HELP,,,AM FED UP

    • You may have a short in the wires. I would address the P0236 sensor first. That may be the reason why your car goes into limp mode.

  14. Hi, I have GL500 2009. Every time I shift the transmission from P to D particularly every morning or first time after long parking or when the car on the climb position, the transmission iis very rough and noisy. Any advice?
    Looking forward for your feedback . Regards

    • Have you checked the fluid level. It may help to do a transmission oil change. The valve body may also be the issue.

  15. Hello I have 2 codes P0137 and P2038 with rough idle on a clk200 mercedes
    Can you help me?

    • P0137 Oxygen Sensor Circuit Low Voltage B1S2

      P2038 – Reductant Injection Air Pressure Sensor ‘A’ Circuit Range/Performance

  16. Hi,

    I’m interested in purchasing a module that can calibrate and manually adjust my 2013 Mercedes CLS550 w218 Airmatic suspension. Please let me know which product to purchase.

    Thank you,
    Levi

  17. Hi. I really need your advise about my W204 Mercedes Bens Flip Flap Screen. The radio is working normal even though the screen just went too dim/almost black. I can no longer access my navigation, CD player visible instructions. What must I check? The local dealer recommended that I buy a new screen at a high price. I total disagree as sometimes the screen seems to slightly visible especially if I being at a particular angle of the sun. Please advise. My contact email is makateng@vodamail.co.za

  18. Hi. I have a c350 2011. My command stopped working after a slight bump ( Air bags ok ). Is there a way to reset or test this unit. Please help. Regards.

Leave a Reply

Your email address will not be published. Required fields are marked *

All rights reserved Notice: LQW